找回密码
 立即注册

[笔记] 避坑 Discuz! X3.4 升级至 Discuz! X3.5

[复制链接]
69伙伴 发表于 2023-12-23 16:24:23 | 显示全部楼层 |阅读模式
https://www.dismall.com/thread-15914-1-1.html

按照上面的官方步骤升级,uc升级到1.7之后
在升级dz论坛,结果发现 提示UC版本.16
第一开始我也走了弯路,解决这个问题
  1. 对没错就是 dz主目录下的 dz论坛配置的UC链接文件.
  2. config\config_ucenter.php
  3. 倒数第4行 看看是不是指定了ucserve
  4. define('UC_API', 'http://xxxx.xxxx/uc_server');
  5. 改为
  6. define('UC_API', 'uc_server');
复制代码


2e22b8cd231f9fcd2700d53757363672.png





以下可能用不到了,没啥必要看了.


安装官方步骤操作

1.下载最新版本dz
  1. https://www.dismall.com/thread-15914-1-1.html
复制代码

2.将自己旧版的dz 数据库配置文件 拷贝到最新dz里
  1. dz论坛下的 uc数据库配置文件
  2. \uc_server\data\config.inc.php
  3. dz论坛下 数据库配置文件
  4. \config\config_global.php
  5. \config\config_ucenter.php
复制代码
3.先升级UC

官方 update_ucenter_adult.zip
UC1.6升级到1.7的官方升级文件,放置并且访问 按照提示完成升级

update_ucenter_adult.zip (17.11 KB, 下载次数: 37)
  1. /uc_server/install/update_ucenter_adult.php
复制代码
4.重点 升级dz
update_adult.zip 文件放置别访问
/install/update_adult.php
这里会出现禁止升级  uc版本不对的提示.
但是步骤3.uc升级成功 提示uc版本1.7

  1. 可以查看数据库表 下的version 确定下uc版本
  2. pre_ucenter_settings
复制代码

自己修改下 强制安装
大概129行
修改UCenter' => '1.6.0'  

  1. 原始内容
  2. $req_ver = array('Code Version' => '3.5', 'UCenter' => '1.7.0', 'PHP' => '5.6.0', 'MySQL' => '5.5.3', 'GD' => '1.0', 'XML' => true, 'JSON' => true, 'mbstring' => true, 'Not Slave' => true, 'Not DB Map' => true);
复制代码

修改完成的 DZ3.4 升级 DZ3.5的官方文件
update_adult.zip (22.79 KB, 下载次数: 44)


总结:
本站测试升级一切正常 从
Discuz! X3.4 R20230520 UTF-8
升级到 今日最新版
Discuz! X3.5 Release 20231221 UTF-8


临时交流 ⇨点我留言
【附件·直下】非必要·勿注册

网格·联系我们 ( 京ICP备16001788号|京公网安备 11010502049360号 ) | 网站地图 | 2012- WGPro.CoM |

GMT+8, 2024-5-23 19:37

Powered by Discuz! X3.5

© 2001-2024 Discuz! Team.

快速回复 返回顶部 返回列表